npm 爆重大漏洞使得 Linux 系统崩溃

npm 重大漏洞使得 Linux 系统崩溃,强制用户重新安装。npm用户Crunkle指出,npm 5.7.0完全破坏了他的文档系统权限,使得他必须手动修复重大文档与文件夹的权限。
图片[1]-npm 爆重大漏洞使得 Linux 系统崩溃-孤勇者社区

npm的全名为Node Package Manager,它是JavaScript程序语言的包管理器,也是Node.js预设的包管理器。为Node.js,Ember,jQuery,Bootstrap,React,Angular和许多其他JavaScript框架提供库和插件。

根据GitHub上的npm臭虫报告,npm用户Crunkle指出,npm 5.7.0完全破坏了他的文档系统权限,使得他必须手动修补重大文档与文件夹的权限。另一名用户juggy则表示,单次的npm 5.7.0部署就摧毁了3台运作中的服务器。AWS EC2的Linux AMI用户redboltz也说,他在部署npm 5.7.0之后便无法执行sudo指令,只好重建EC2实例。变更文档权限可能造成程序或系统崩溃,甚至无法开机。

npm,Inc.隔天就释出了npm 5.7.1进行修补。由于该公司采用npm@next与npm@latest的两阶段更新,npm 5.7.0率先发布至npm@next,当未波及npm@ latest,因此,采用npm@ latest更新渠道的用户尚未受到影响。

------本页内容已结束,喜欢请分享------

感谢您的来访,获取更多精彩文章请收藏本站。

© 版权声明
THE END
喜欢就支持一下吧
点赞5赞赏 分享
评论 抢沙发
头像
欢迎您留下宝贵的见解!
提交
头像

昵称

取消
昵称表情代码图片